0 comments

Okay, so it’s getting really annoying now. Every morning I have to spend about 30 minutes deleting comment spam from my blog. Just this morning, here’s what my GMail inbox looked like:

 blogspam

 

I’ve tried to enable the akismet extension, but something isn’t quite right – at least not when I upload my blog to my hosting provider (Surftown). When I add the extension, my extensions config page goes empty (or only shows 1 or 2 extensions – it differs). To rule out the possibility of a bug in the akismet extension, I tried adding a much simpler extension that doesn’t really do anything. Here’s the code:

using System;
using System.Web;
using BlogEngine.Core;
using BlogEngine.Core.Web;
using BlogEngine.Core.Web.Controls;
using BlogEngine.Core.Web.HttpHandlers;

[Extension("Just a test!", "0.1", "Graffen")]
public class TestExtension
{
  static TestExtension()
  {

  }
}

Before adding this extension to the app_code folder on my blog at Surftown, here’s what the extension settings page looked like:

  extensions_b4_add_new

And here’s the same list, after only adding the above file:

 extensions_after_add_new

Deleting the file again brings back all the other extensions – so it must have something to do either with the extension handler, or with a configuration issue at my hosting provider.

There’s nothing in my error log, and the application isn’t throwing any exceptions (at least none that I can see). Anyone have any ideas? Please post a comment if you do (but if your name is “payday loans” I’ll just delete your posting) I’m running BlogEngine.NET 1.5.0.7 on a shared host at Surftown Denmark.

comments powered by Disqus